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User Guide 

N32H7xx series Dual-Core Debugging user guide  

Introduction  

This document is designed for users to quickly understand the usage of Dual-Core Debugging in N32H7xx series 

microcontrollers (MCUs), in order to guide users to easily understand and resolve issues related to dual-core debugging. 
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1 IAR Embedded Workbench® Environment 

 Using CMSIS_DAP 

For CMSIS_DAP, IAR provides a method for debugging two cores of different architectures simultaneously. 

Asymmetric multicore processing (where one core is M7 and the other is M4) can be configured from two different 

core configurations within the same project or from two separate workspaces. 

 Project Configuration 

The following example creates a project and adds separate configurations for the two cores respectively. 

1.1.1.1 CM4 Project Configuration 

 Open IAR and create a workspace, then save the workspace. 

 Create a project and add program files to it. 

 Name the Configuration of the newly created Project as debug for easy identification of M4 and M7 

configurations. You can create a new Configuration named N32H78x_CM4 via Project → Edit Configurations 

→ New, then switch to the N32H78x_CM4 Configuration and delete the debug/release configuration. 

Figure 1-1 Adding M4 Configuration 

 

 Configure the project - Select M4 device: Project → Options → General Options → Target 
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Figure 1-2 Select M4 Device 

 

 Configure the project – Set Linker: Project → Options → Linker → Config. The default setting is the icf file 

under the IAR path. After checking Override default, you can reselect and edit your own linker file. 

Figure 1-3 Setting Linker 

 

 Configure the project – Select debugger: Project → Options → Debugger → Setup. Select CMSIS-DAP for 

the Driver. 
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Figure 1-4 Selecting Debugger 

 

 Configure the project – Select reset mode for CMSIS_DAP: Project → Options → CMSIS DAP → Setup. 

Only software and core reset modes can be selected; system/hardware reset will reset the entire system, resulting 

in debugger connection failure. 

Figure 1-5 Selecting Reset Mode for CMSIS_DAP 

 

 Configure the project – Check Restore software breakpoint at _call_main: Project → Options → CMSIS DAP 

→ Breakpoints 
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Figure 1-6 Enabling Restore software breakpoint at_call_main 

 

1.1.1.2 CM7 Project Configuration 

 Add M7 configuration based on the M4 project: Project → Edit Configurations → New. The configuration of 

the newly created N32H78x_CM7 is identical to that of M4. 

Figure 1-7 Adding M7 Configuration 

 

 Add M7 program files. For program files exclusive to M4, you can check Exclude from build in the Options of 

the corresponding folder or file to exclude them from compilation. Similarly, program files exclusive to M7 can 

be excluded from compilation in the M4 Configuration. 

Figure 1-8 Excluding Partial Programs from Compilation 
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 Configure the project - Select device: Project → Options → General Options → Target 

Figure 1-9 Selecting M7 Device 

 

 Configure the project – Set Linker: Project → Options → Linker → Config. The default setting is the icf file 

under the IAR path. After checking Override default, you can reselect and edit your own linker file. 

 Configure the project – Select debugger: Project → Options → Debugger → Setup. Select CMSIS-DAP for 

the Driver. 

 Configure the project – Set multicore: Project → Options → Debugger → Multicore.If only single-core 

download and debugging for M7 is required, select Disable for Asymmetric multicore. If dual-core download 

and debugging is required, select Simple for Asymmetric multicore, and set the M4 configuration as the Partner. 

Figure 1-10 Setting Multicore 

 

Partner workspace: Specify the path and file of the CM4 IAR project. 

Partner project: Specify the name of the CM4 project. 

Partner: Specify the name of the sub-project of the CM4 project. 

 Configure the project – Set Extra Options: Project → Options → Debugger → Extra Options. Check Use 

command line options and add --macro_param enable_reset_peripheral=1. Since only software and core reset 

modes are available (system/hardware reset will reset the entire system and cause debugger connection failure), 
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adding --macro_param enable_reset_peripheral=1 allows resetting peripheral registers via RCC before 

executing the reset. 

Figure 1-11 Setting Ectro Options 

 

 Configure the project – Select reset mode for CMSIS_DAP: Project → Options → CMSIS DAP → Setup. 

Only software and core reset modes can be selected; system/hardware reset will reset the entire system, resulting 

in debugger connection failure. 

 Check Restore software breakpoint at _call_main in Project → Options → CMSIS DAP → Breakpoints. 

 Download and Debugging 

Single-core: Select Disable for Asymmetric multicore, then each core can be downloaded and debugged individually, 

but the debug window cannot be entered for both cores at the same time. 

Dual-core: Select Simple for Asymmetric multicore. 

When downloading in the M7 Configuration, the programs for both M7 and M4 will be downloaded; 

When debugging in the M7 Configuration, the M4 project will be opened automatically, the debug window will be 

entered for both cores simultaneously, and breakpoints can be set and debugged for each core separately; 

However, compiling in the M7 Configuration cannot compile the M4 program—compilation of the M4 program can 

only be done in the M4 Configuration. 

Notes: 

1. Currently, only ULINK is supported for dual-core debugging in this manner; 

2. At least four wires (RESET, TMS/SWIO, TCK/SWCLK, GND) need to be connected for ULINK download and 

debugging; 
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Figure 1-12 IAR Dual-Core Debugging Interface 

 

 Using J-Link 

For J-Link, IAR does not support dual-core debugging with Asymmetric multicore. You need to open two IAR 

windows: one window selects the M7 Configuration, and the other selects the M4 Configuration. 

Configuring the J-Link Environment in IAR 

1. Install the J-Link driver, and add Nations chips according to the document Process for Adding Nations Chips to 

JLink Tools. 

2. Copy the JLinkDevices.xml file (with Nations chips added) and the Devices folder to the IAR installation 

path:\Embedded Workbench 9.30\arm\bin 

 Project Configuration 

Based on the project created in the above CMSIS-DAP process, both M4 and M7 Configurations need to select J-

Link/J-Trace as the Driver in Project → Options → Debugger → Setup → Driver.The reset executed during J-Link 

download is not related to the reset mode selected in Options → J-Link/J-Trace, nor will it execute the processes in 

IAR's mac/dmac files. It only executes the reset process defined in the script file:\Embedded Workbench 

8.4\arm\bin\Devices\Nationstech\N32H78x_CM7/4.jlinkscript. 
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Figure 1-13 Selecting J-Link in Debugger 

 

 Check Restore software breakpoint at _call_main in Project → Options → J-Link/J-Trace → Breakpoints 

 Download and Debugging 

For J-Link download and debugging, two IAR windows need to be opened. The debugging steps are as follows: 

1. Open the M7 project code and select the M7 Configuration; then open the M4 project code and select the M4 

Configuration. Compile and download the code to the chip for each core respectively. 

2. Click the debug button for the M7 project code, and let the code run to the line below 

RCC_EnableCM4(0x15080000) to ensure that the M4 core has been correctly released and is running; 

3. Then start the debug session for the CM4 project—the CM4 core will automatically reset and execute to the 

main() function; 

Notes: 

Debugging of the CM4 core can only be started after it is released by the CM7 code. 
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2 Keil MDK-ARM Environment 

As mentioned above, the N32H78x microcontroller integrates a multicore system that includes the Arm® Cortex®-

M7 and Cortex®-M4 processors mentioned in the introduction. 

 Using CMSIS-DAP 

The following example creates a project and adds separate configurations for the two cores respectively. 

 CM7 Project Cofiguration 

 Open the Keil project and create a new project; 

 Configure the project - Select M7 device: Project → Options for Target → Device 

Figure 2-1 Selecting M7 Device 

 

 Configure the project - Select scatter loading: Project → Options for Target → Linker. 

Figure 2-2 Selecting Scatter Loading File 

 

 Configure the project - Select CMSIS-DAP debugger: Project → Options for Target → Debug. 
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Figure 2-3 Selecting Debugger 

 

 Configure the project - Debug Settings. 

Figure 2-4  Debugger Setting 

 

1. Select the Access Ports: set AP0 to CM7 and AP2 to CM4; 

2. Select the same download options as those in the window; 

 Auto Detect: The system selects the most appropriate reset mode for the target device. 

 Hardware Reset: Executes a hardware reset by triggering the hardware reset signal. 

 System Reset Request: Executes a software reset by setting the SYSRESETREQ bit. The Cortex-Mx core and 

on-chip peripherals will be reset. 

 Vector Reset: Executes a software reset by setting the VECTRESET bit. Only the core will be reset. 

3. Select the Connection and Reset options: 

 Normal: Stops the CPU at the currently executing instruction after connection. 

 Pre-reset: Executes a hardware reset before connecting to the device. 

 Under Reset: Keeps the hardware reset signal active when connecting to the device. 

 Configure the project - Flash Download Settings. 
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Figure 2-5 Flash Download 

 

1. Download Function: 

2. RAM for Download Algorithm: Defines the address space used to load and execute the programming algorithm. 

Typically, this address space is located in on-chip RAM; 

3. Programming Algorithm: Included download algorithms 

4. Note: This address is the maximum available address of the flash. The FLASH usage plan of the N32H78x chip 

can be configured according to your actual usage. For example:CM7 occupies the address range: 0x15000000 - 

0x15080000, CM4 occupies the address range: 0x15080000 – 0x151E0000. 

 CM4 Project Configuration 

 Open the Keil project and create a new project; 

 Configure the project - Select M4 device: Project → Options for Target → Device 

Figure 2-6 Selecting M4 Device 

 

 Configure the project - Select scatter loading: Project → Options for Target → Linker. 



                                                                                                                                       nsing.com.sg 

13 

 

Figure 2-7 Selecting Scatter Loading File 

 

 Configure the project - Select CMSIS-DAP debugger: Project → Options for Target → Debug. 

Figure 2-8 Selecting Debugger 

 

 Configure the project - Debug Settings. 

Figure 2-9 Debug Setting 

 

1. Select the Access Port: set AP2 to CM4; 

2. Select the same download options as those in the window; Note: Select VECTRESET for M4. 
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3. Select the Connection and Reset options: 

 Configure the project - Flash Download Settings. 

Figure 2-10 Flash Download 

 

 Download and Debugging 

For CMSIS-DAP download and debugging, two Keil windows need to be opened. The debugging steps are as follows: 

1. Open the M7 project code and select the M7 Configuration; then open the M4 project code and select the M4 

Configuration. Compile and download the code to the chip for each core respectively. 

2. Click the debug button for the M7 project code, and let the code run to the line below 

RCC_EnableCM4(0x15080000) to ensure that the M4 core has been correctly released and is running; 

3. Then start the debug session for the CM4 project, reset the CM4 core to the first line of code, and then step 

through the code to the main() function; 

Notes: 

After the CM4 core is reset, it can only be debugged step-by-step to the main() function. If a software breakpoint is 

set inside the main() function, it will not take effect. This issue is caused by Keil MDK534 failing to update the 

breakpoint address. 
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Figure 2-11 keil Dual-Core Debugging Interface 

 

Notes: 

1. The CM4 core can only start debugging after being released by the CM7 code; 

2. A system reset of the CM7 core will cause the CM4 core (which is in the debug interface) to disconnect from the 

debug session; 

 Using J-Link 

For J-Link, Keil does not support dual-core synchronous debugging. You need to open two Keil windows: one 

window selects the M7 Configuration, and the other selects the M4 Configuration. 

 J-Link Environment Configuration 

1. Install the J-Link driver, and add Nations chips according to the document Process for Adding Nations Chips to 

JLink Tools. 

2. For J-Link versions V7.7 and above, no special addition is required during installation—it can be used directly 

after installation. 

3. For J-Link versions below V7.7, need to add the JLinkDevices.ref file to the directory: .\Keil_v5\ARM\Segger. 

In this file, simply specify the installation path of J-Link, for example: "C:\Program Files\SEGGER\JLink\". 

 CM7 and CM4 Project Configuration 

Based on the project created in the above Keil CMSIS-DAP process, both M4 and M7 Configurations need to select 

J-Link/J-Trace Cortex in Project → Options for Target → Debug. 
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Figure 2-12 Selecting Debugger 

 

The reset executed during J-Link download is not related to the reset mode selected in Options → J-Link/J-Trace → 

Settings — it only executes the reset process defined in the script file:\C:\Program 

Files\SEGGER\JLink\Devices\Nationstech\N32H78x_CM7.jlinkscript. 

 Download and Debugging 

The steps are identical to those of CMSIS-DAP under Keil; for details, refer to Section 2.2 Download and Debugging. 
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3 Notes on Debugging Issues 

 Summary of Common Issues 

If users encounter failure to download or enter debugging, the following two solutions are available: 

1. Power cycle the chip (power off and then power on again). 

2. If the above solution does not resolve the issue, use the Nations host computer to pull up the BOOT pin, erase 

the user code, and then power on the chip again. 



                                                                                                                                       nsing.com.sg 

18 

 

4 History versions 

Version Date Notes 

V1.0.0 2025-7-10 Initial version 
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5 Disclaimer 

This document is the exclusive property of NSING TECHNOLOGIES PTE. LTD. (Hereinafter 

referred to as NSING). This document, and the product of NSING described herein (Hereinafter 

referred to as the Product) are owned by NSING under the laws and treaties of Republic of Singapore 

and other applicable jurisdictions worldwide. The intellectual properties of the product belong to 

NSING Technologies Inc. and NSING Technologies Inc. does not grant any third party any license 

under its patents, copyrights, trademarks, or other intellectual property rights. Names and brands of 

third party may be mentioned or referred thereto (if any) for identification purposes only. NSING 

reserves the right to make changes, corrections. enhancements, modifications, and improvements to 

this document at any time without notice. Please contact NSING and obtain the latest version of this 

document before placing orders. Although NSING has attempted to provide accurate and reliable 

information, NSING assumes no responsibility for the accuracy and reliability of this document. It is 

the responsibility of the user of this document to properly design, program, and test the functionality 

and safety of any application made of this information and any resulting product. In no event shall 

NSING be liable for any direct, indirect, incidental, special, exemplary, or consequential damages 

arising in any way out of the use of this document or the Product. NSING Products are neither intended 

nor warranted for usage in systems or equipment, any malfunction or failure of which may cause loss 

of human life, bodily injury or severe property damage. Such applications are deemed, Insecure Usage’. 

Insecure usage includes, but is not limited to: equipment for surgical implementation, atomic energy 

control instruments, airplane or spaceship instruments, all types of safety devices, and other 

applications intended to supporter sustain life. All Insecure Usage shall be made at user's risk. User 

shall indemnify NSING and hold NSING harmless from and against all claims, costs, damages, and 

other liabilities, arising from or related to any customer's Insecure Usage Any express or implied 

warranty with regard to this document or the Product, including, but not limited to. The warranties of 

merchantability, fitness for a particular purpose and non-infringement are disclaimed to the fullest 

extent permitted by law. Unless otherwise explicitly permitted by NSING, anyone may not use, 

duplicate, modify, transcribe or otherwise distribute this document for any purposes, in whole or in 

part. 
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